<!doctype html><html
lang=en-US id=arve><head><meta
name=viewport content="width=device-width, initial-scale=1, maximum-scale=1, minimum-scale=1"><meta
charset=UTF-8><title>$600M Mega Millions, $550M Powerball Jackpots Up For Grabs This Week</title><link
rel=preload href=/assets/fonts/IBM-Plex-Sans/IBMPlexSans-Bold.woff as=font type=font/woff crossorigin><link
rel=preload href=/assets/fonts/IBM-Plex-Sans/IBMPlexSans-Bold.woff2 as=font type=font/woff2
crossorigin><link
rel=preload href=/assets/fonts/IBM-Plex-Sans/IBMPlexSans-Regular.woff as=font type=font/woff
crossorigin><link
rel=preload href=/assets/fonts/IBM-Plex-Sans/IBMPlexSans-Regular.woff2 as=font type=font/woff2
crossorigin><link
crossorigin rel="preconnect dns-prefetch" href=https://sa.casino.org><link
crossorigin rel="preconnect dns-prefetch" href=https://assets.adobedtm.com/ ><title>$600M Mega Millions, $550M Powerball Jackpots Up For Grabs This Week</title><meta
name=description content="This marks the first time since October 2018 when both the Powerball and Mega Millions jackpots have been this high at the same time."><meta
name=robots content="index, follow"><meta
name=googlebot content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><meta
name=bingbot content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><link
rel=canonical href=https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/ ><meta
property=og:locale content=en_US><meta
property=og:type content=article><meta
property=og:title content="$600M Mega Millions, $550M Powerball Jackpots Up For Grabs This Week"><meta
property=og:description content="This marks the first time since October 2018 when both the Powerball and Mega Millions jackpots have been this high at the same time."><meta
property=og:url content=https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/ ><meta
property=og:site_name content=Casino.org><meta
property=article:publisher content=https://www.facebook.com/Casino.OrgNews><meta
property=article:published_time content=2021-01-11T07:59:55+00:00><meta
property=article:modified_time content=2021-01-11T17:44:44+00:00><meta
property=og:image content=https://www.casino.org/news/wp-content/uploads/2021/01/LRTCLHBTCAI6NEOSRJB777NNOU.jpg><meta
property=og:image:width content=1024><meta
property=og:image:height content=678><meta
name=twitter:card content=summary><meta
name=twitter:creator content=@Casino_Org><meta
name=twitter:site content=@Casino_Org> <script type=application/ld+json class=yoast-schema-graph>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.casino.org/news/#website","url":"https://www.casino.org/news/","name":"Casino.org","description":"Online Casinos News","potentialAction":[{"@type":"SearchAction","target":"https://www.casino.org/news/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/#primaryimage","inLanguage":"en-US","url":"https://www.casino.org/news/wp-content/uploads/2021/01/LRTCLHBTCAI6NEOSRJB777NNOU.jpg","width":1024,"height":678,"caption":"The lottery balls for Mega Millions jackpot before they are released into the machine for a 2013 drawing. On Tuesday, the Mega Millions jackpot will be worth an estimated $600 million. On Wednesday,Powerball, another multi-state lottery, will hold a drawing for an estimated $550 million prize. (Image: Reuters)"},{"@type":"WebPage","@id":"https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/#webpage","url":"https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/","name":"$600M Mega Millions, $550M Powerball Jackpots Up For Grabs This Week","isPartOf":{"@id":"https://www.casino.org/news/#website"},"primaryImageOfPage":{"@id":"https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/#primaryimage"},"datePublished":"2021-01-11T07:59:55+00:00","dateModified":"2021-01-11T17:44:44+00:00","author":{"@id":"https://www.casino.org/news/#/schema/person/eb30e765d812fc9b38b333f8d13068b2"},"description":"This marks the first time since October 2018 when both the Powerball and Mega Millions jackpots have been this high at the same time.","breadcrumb":{"@id":"https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/"]}]},{"@type":"BreadcrumbList","@id":"https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.casino.org/news/","url":"https://www.casino.org/news/","name":"News"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.casino.org/news/lottery/","url":"https://www.casino.org/news/lottery/","name":"Lottery"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/","url":"https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/","name":"$600M Mega Millions, $550M Powerball Jackpots Up For Grabs This Week"}}]},{"@type":"Person","@id":"https://www.casino.org/news/#/schema/person/eb30e765d812fc9b38b333f8d13068b2","name":"Steve Bittenbender","image":{"@type":"ImageObject","@id":"https://www.casino.org/news/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a5690be520bbcd0e2d02bcb45d2f2b41?s=96&d=mm&r=g","caption":"Steve Bittenbender"},"description":"Horse Racing, Sports Betting, Gaming Legislation, Midwest and Gulfport Casinos----Steve Bittenbender is a veteran reporter, and brings more than two decades of experience covering sports, gaming business, and politics and legislation to Casino.org, which he joined in 2019. Based in Louisville, Kentucky -- the epicenter of the US horse racing industry -- Steve has also covered major collegiate and professional sports for the Associated Press and the Louisville Courier Journal. A Reuters contributor, he has also previously served as editor for Government Security News. Steve lives with his wife and son in Louisville and is an avid poker player, having learned from his uncle as a wholesome after-school pasttime with cookies and milk. Email: stevebittenbender@casino.org"}]}</script> <link
rel=dns-prefetch href=//s.w.org><link
rel=alternate type=application/rss+xml title="Casino.org &raquo; Feed" href=https://www.casino.org/news/feed/ ><link
rel=alternate type=application/rss+xml title="Casino.org &raquo; Comments Feed" href=https://www.casino.org/news/comments/feed/ ><link
rel=alternate type=application/rss+xml title="Casino.org &raquo; $600M Mega Millions, $550M Powerball Jackpots Up For Grabs This Week Comments Feed" href=https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/feed/ ><link
rel=https://api.w.org/ href=https://www.casino.org/news/wp-json/ ><link
rel=EditURI type=application/rsd+xml title=RSD href=https://www.casino.org/news/xmlrpc.php?rsd><link
rel=wlwmanifest type=application/wlwmanifest+xml href=https://www.casino.org/news/wp-includes/wlwmanifest.xml><meta
name=generator content="WordPress 5.4.4"><link
rel=shortlink href='https://www.casino.org/news/?p=160867'><link
rel=alternate type=application/json+oembed href="https://www.casino.org/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.casino.org%2Fnews%2F600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week%2F"><link
rel=alternate type=text/xml+oembed href="https://www.casino.org/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.casino.org%2Fnews%2F600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week%2F&#038;format=xml"> <script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.casino.org\/news\/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week\/"},"url":"https:\/\/www.casino.org\/news\/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week\/","headline":"$600M Mega Millions, $550M Powerball Jackpots Up For Grabs This...","datePublished":"2021-01-10T23:59:55-08:00","dateModified":"2021-01-11T09:44:44-08:00","publisher":{"@type":"Organization","@id":"https:\/\/www.casino.org\/news\/#organization","name":"Casino.org","logo":{"@type":"ImageObject","url":"https:\/\/www.casino.org\/news\/wp-content\/uploads\/2019\/08\/corg-logo-amp.jpg","width":600,"height":60}},"image":{"@type":"ImageObject","url":"https:\/\/www.casino.org\/news\/wp-content\/uploads\/2021\/01\/LRTCLHBTCAI6NEOSRJB777NNOU.jpg","width":1024,"height":678},"articleSection":"Financial","description":"Neither the Mega Millions grand prize nor the Powerball jackpot were claimed this weekend. That means the multi-state lottery games’ upcoming mid-week drawings will be for two of the richest prizes ever. The lottery balls for Mega Millions jackpot before they are released into the machine for a 2013","author":{"@type":"Person","name":"Steve Bittenbender","url":"https:\/\/www.casino.org\/news\/author\/steve-bittenbender\/","description":"Horse Racing, Sports Betting, Gaming Legislation, Midwest and Gulfport Casinos----Steve Bittenbender is a veteran reporter, and brings more than two decades of experience covering sports, gaming business, and politics and legislation to Casino.org, which he joined in 2019. Based in Louisville, Kentucky -- the epicenter of the US horse racing industry -- Steve has also covered major collegiate and professional sports for the Associated Press and the Louisville Courier Journal. A Reuters contributor, he has also previously served as editor for Government Security News. Steve lives with his wife and son in Louisville and is an avid poker player, having learned from his uncle as a wholesome after-school pasttime with cookies and milk. Email: stevebittenbender@casino.org","image":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/a5690be520bbcd0e2d02bcb45d2f2b41?s=96&d=mm&r=g","height":96,"width":96}},"video":[null,null],"audio":[null,null],"commentCount":"0"}</script> <script>window._wp_rp_static_base_url = 'https://wprp.zemanta.com/static/';
	window._wp_rp_wp_ajax_url = "https://www.casino.org/news/wp-admin/admin-ajax.php";
	window._wp_rp_plugin_version = '3.6.4';
	window._wp_rp_post_id = '160867';
	window._wp_rp_num_rel_posts = '5';
	window._wp_rp_thumbnails = true;
	window._wp_rp_post_title = '%24600M+Mega+Millions%2C+%24550M+Powerball+Jackpots+Up+For+Grabs+This+Week';
	window._wp_rp_post_tags = ['financial', 'lottery', 'fridai', 'grand', '2013', 'award', 'powerbal', 'cash', 'prize', 'mega', 'midweek', 'histori', 'game', 'machin', 'lotteri', 'ball', 'jackpot'];
	window._wp_rp_promoted_content = false;</script> <style>.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link
rel=amphtml href=https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/amp/ ><link
rel=icon href=https://www.casino.org/news/wp-content/uploads/2019/06/cropped-corg-favicon-512-1-32x32.png sizes=32x32><link
rel=icon href=https://www.casino.org/news/wp-content/uploads/2019/06/cropped-corg-favicon-512-1-192x192.png sizes=192x192><link
rel=apple-touch-icon href=https://www.casino.org/news/wp-content/uploads/2019/06/cropped-corg-favicon-512-1-180x180.png><meta
name=msapplication-TileImage content=https://www.casino.org/news/wp-content/uploads/2019/06/cropped-corg-favicon-512-1-270x270.png><link
crossorigin rel="preconnect dns-prefetch" href=https://cdn.speedcurve.com> <script>LUX=(function(){var a=("undefined"!==typeof(LUX)&&"undefined"!==typeof(LUX.gaMarks)?LUX.gaMarks:[]);var d=("undefined"!==typeof(LUX)&&"undefined"!==typeof(LUX.gaMeasures)?LUX.gaMeasures:[]);var j="LUX_start";var k=window.performance;var l=("undefined"!==typeof(LUX)&&LUX.ns?LUX.ns:(Date.now?Date.now():+(new Date())));if(k&&k.timing&&k.timing.navigationStart){l=k.timing.navigationStart}function f(){if(k&&k.now){return k.now()}var o=Date.now?Date.now():+(new Date());return o-l}function b(n){if(k){if(k.mark){return k.mark(n)}else{if(k.webkitMark){return k.webkitMark(n)}}}a.push({name:n,entryType:"mark",startTime:f(),duration:0});return}function m(p,t,n){if("undefined"===typeof(t)&&h(j)){t=j}if(k){if(k.measure){if(t){if(n){return k.measure(p,t,n)}else{return k.measure(p,t)}}else{return k.measure(p)}}else{if(k.webkitMeasure){return k.webkitMeasure(p,t,n)}}}var r=0,o=f();if(t){var s=h(t);if(s){r=s.startTime}else{if(k&&k.timing&&k.timing[t]){r=k.timing[t]-k.timing.navigationStart}else{return}}}if(n){var q=h(n);if(q){o=q.startTime}else{if(k&&k.timing&&k.timing[n]){o=k.timing[n]-k.timing.navigationStart}else{return}}}d.push({name:p,entryType:"measure",startTime:r,duration:(o-r)});return}function h(n){return c(n,g())}function c(p,o){for(i=o.length-1;i>=0;i--){var n=o[i];if(p===n.name){return n}}return undefined}function g(){if(k){if(k.getEntriesByType){return k.getEntriesByType("mark")}else{if(k.webkitGetEntriesByType){return k.webkitGetEntriesByType("mark")}}}return a}return{mark:b,measure:m,gaMarks:a,gaMeasures:d}})();LUX.ns=(Date.now?Date.now():+(new Date()));LUX.ac=[];LUX.cmd=function(a){LUX.ac.push(a)};LUX.init=function(){LUX.cmd(["init"])};LUX.send=function(){LUX.cmd(["send"])};LUX.addData=function(a,b){LUX.cmd(["addData",a,b])};LUX_ae=[];window.addEventListener("error",function(a){LUX_ae.push(a)});LUX_al=[];if("function"===typeof(PerformanceObserver)&&"function"===typeof(PerformanceLongTaskTiming)){var LongTaskObserver=new PerformanceObserver(function(c){var b=c.getEntries();for(var a=0;a<b.length;a++){var d=b[a];LUX_al.push(d)}});try{LongTaskObserver.observe({type:["longtask"]})}catch(e){}};</script><script src="https://cdn.speedcurve.com/js/lux.js?id=588347437" async defer crossorigin=anonymous></script> <script src="https://cdn.speedcurve.com/js/lux.js?id=588347437" async defer crossorigin=anonymous></script> <meta
name=author content="Steve Bittenbender"><meta
name=title content="$600M Mega Millions, $550M Powerball Jackpots Up For Grabs This Week"><meta
name=publishedDate content="January 10, 2021"><meta
name=modifiedDate content="January 11, 2021"><meta
name=categories content="Financial || Lottery"><meta
name=commentCount content=0><style>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</style> <script src=/assets/js/WP-Hendrix-Theme-ATF.4c7554f914c6cabd6f1c.js></script> <meta
class=swiftype name=description data-type=string content="This marks the first time since October 2018 when both the Powerball and Mega Millions jackpots have been this high at the same time."><meta
class=swiftype name=page_language data-type=string content=de_DE><meta
class=swiftypbowie-search-bar__inpute name=page_category data-type=string content=news></head><body
class="post-template-default single single-post postid-160867 single-format-standard"><div
class=wrapper><header
class=header><div
class="container header__container"><div
class=header__brand-holder>
<a
href=/ class=header__logo-link>
<img
src=/assets/media/images/global/logo/25year/logo-casino-org-25years-no-trademark.svg
alt=Casino.org
class=header__logo-image>
</a>
<span
class=header__brand-text>
The World's Online Gaming Authority Since 1995 </span></div><div
class="global-search js-open-close">
<button
type=submit class="global-search__button js-opener">
<i
class="icon-search open"></i>
<span
class="global-search__button-title open">Search</span>
<i
class="icon-cancel close"></i>
<span
class="global-search__button-title close">Сlose</span>
</button><form
method=get class=global-search__form role=search action=https://www.casino.org/news/ >
<button
type=submit class=global-search__submit>
<i
class=icon-search></i>
</button>
<input
type=search value name=s id=s  class=global-search__input placeholder=Search...></form></div>
<a
href=# class="header__mobile-opener js-mobile-nav-opener">
<span
class=header__mobile-burger></span>
<span
class=header__mobile-burger-title>Menu</span>
</a><div
class="header__nav-holder js-mobile-drop-holder">
<a
href=# class="header__mobile-close js-mobile-nav-close">
<i
class=icon-cancel></i>
<span>Сlose</span>
</a><nav
class=header__nav><ul
id=menu-main-menu-dev class=main-nav><li
id=nav-menu-item-29859 class="main-nav__nav-item  "><a
href=https://www.casino.org/news/ class=main-nav__link>News Home</a></li><li
id=nav-menu-item-97546 class="main-nav__nav-item  "><a
href=https://www.casino.org/news/commercial-gaming/ class=main-nav__link>Commercial Gaming</a></li><li
id=nav-menu-item-97547 class="main-nav__nav-item  "><a
href=https://www.casino.org/news/tribal-gaming/ class=main-nav__link>Tribal Gaming</a></li><li
id=nav-menu-item-29860 class="main-nav__nav-item  "><a
href=https://www.casino.org/news/legislation/ class=main-nav__link>Legislation</a></li><li
id=nav-menu-item-97548 class="main-nav__nav-item  "><a
href=https://www.casino.org/news/sportsbetting/ class=main-nav__link>Sports Betting</a></li><li
id=nav-menu-item-97549 class="main-nav__nav-item  "><a
href=https://www.casino.org/news/crime/ class=main-nav__link>Crime</a></li><li
id=nav-menu-item-29865 class="main-nav__nav-item   main-nav__nav-item--has-drop"><a
class=main-nav__link>More</a><ul
class=main-nav__sub-nav><li
id=nav-menu-item-97553 class="main-nav__sub-item  "><a
href=https://www.casino.org/news/mergers-and-acquisitions/ class=main-nav__sub-link>Mergers and Acquisitions</a></li><li
id=nav-menu-item-29870 class="main-nav__sub-item  "><a
href=https://www.casino.org/news/live-casinos/ class=main-nav__sub-link>Live Casinos</a></li><li
id=nav-menu-item-29868 class="main-nav__sub-item  "><a
href=https://www.casino.org/news/internet-gaming/ class=main-nav__sub-link>Internet Gaming</a></li><li
id=nav-menu-item-97551 class="main-nav__sub-item  "><a
href=https://www.casino.org/news/scandals/ class=main-nav__sub-link>Scandals</a></li><li
id=nav-menu-item-97550 class="main-nav__sub-item  "><a
href=https://www.casino.org/news/regulation/ class=main-nav__sub-link>Regulation</a></li></ul></li></ul></nav></div></header><main
class=content><section
class=post-content><div
class=container><nav
class=breadcrumbs><ul
class=breadcrumbs__list><li
class=breadcrumbs__item><a
class=breadcrumbs__link href=https://www.casino.org/news/ >News</a></li><li
class=breadcrumbs__item><a
class=breadcrumbs__link href=https://www.casino.org/news/lottery/ >Lottery</a></li></ul></nav><div
class=inner-wrapper><div
class=inner-content><div
class="post-content__share-holder desktop-only"><div
class=post-content__share-title>Share this:</div><ul
class=share-social><li
class=share-social__item><a
target=_blank href="http://www.facebook.com/sharer.php?u=https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/" class=share-social__link><i
class=icon-facebook></i>
</a></li><li
class=share-social__item> <a
target=_blank href="https://twitter.com/share?url=https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/" class=share-social__link>
<i
class=icon-twitter></i>  </a></li><li
class=share-social__item><a
target=_blank href="http://www.linkedin.com/shareArticle?url=https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/" class=share-social__link><i
class=icon-linkedin></i></a></ul></div><div
class=post-content__content><h1 class="post-content__main-title">$600M Mega Millions, $550M Powerball Jackpots Up For Grabs This Week</h1><p
class=post-content__sub-title>
Posted on: January 10, 2021, 11:59h.&nbsp;</p><p
class=post-content__sub-title>
Last updated on: January 11, 2021, 09:44h.<div
class=post-info-panel><div
class="post-info-panel__author-holder js-open-close"><div
class=post-info-panel__author-logo>
<img
alt='Steve Bittenbender' src=https://www.casino.org/news/wp-content/uploads/2019/04/Steve-Bittenbender-CORG-bio-96x96.jpg class='avatar avatar-96 photo' height=96 width=96></div><div
class=post-info-panel__author-content><div
class=post-info-panel__author-info>
<span
class=post-info-panel__author-name>
<a
title="Steve Bittenbender"
href=https://www.casino.org/news/author/steve-bittenbender/ >
Steve Bittenbender </a>
</span>
<a
href=#
class="post-info-panel__opener tablet-none js-opener">Read More</a><div
class=post-info-panel__expertise>
Expertise:
<span
class=post-info-panel__expertise-items>
<a
class=post-info-panel__expertise-link
href=https://www.casino.org/news/horse-racing/
title="Horse Racing">Horse Racing</a>, <a
class=post-info-panel__expertise-link
href=https://www.casino.org/news/legislation/
title=Legislation>Legislation</a>, <a
class=post-info-panel__expertise-link
href=https://www.casino.org/news/sportsbetting/
title="Sports Betting">Sports Betting</a>. </span></div></div><ul
class=social-list><li
class=social-list__item>
<a
href=mailto:stevebittenbender@casino.org class="social-list__link icon-mail"
ref="nofollow noopener noreferrer" target=_blank></a></li></ul></div></div></div><p>Neither the Mega Millions grand prize nor the Powerball jackpot were claimed this weekend. That means the multi-state lottery games’ upcoming mid-week drawings will be for two of the richest prizes ever.</p><figure
id=attachment_160868 aria-describedby=caption-attachment-160868 data-style="width: 1200px" class="wp-caption aligncenter"><img
class="wp-image-160868 lazyload"
src=https://www.casino.org/news/wp-content/uploads/2021/01/LRTCLHBTCAI6NEOSRJB777NNOU-142x94.jpg data-src=https://www.casino.org/news/wp-content/uploads/2021/01/LRTCLHBTCAI6NEOSRJB777NNOU-142x94.jpg
alt="Mega Millions Powerball" width=1200 height=795
data-srcset="https://www.casino.org/news/wp-content/uploads/2021/01/LRTCLHBTCAI6NEOSRJB777NNOU.jpg 1024w, https://www.casino.org/news/wp-content/uploads/2021/01/LRTCLHBTCAI6NEOSRJB777NNOU-142x94.jpg 142w, https://www.casino.org/news/wp-content/uploads/2021/01/LRTCLHBTCAI6NEOSRJB777NNOU-768x509.jpg 768w, https://www.casino.org/news/wp-content/uploads/2021/01/LRTCLHBTCAI6NEOSRJB777NNOU-453x300.jpg 453w" sizes="(max-width: 1200px) 100vw, 1200px" \>
<noscript><img
class=wp-image-160868 src=https://www.casino.org/news/wp-content/uploads/2021/01/LRTCLHBTCAI6NEOSRJB777NNOU.jpg alt="Mega Millions Powerball" width=1200 height=795 srcset="https://www.casino.org/news/wp-content/uploads/2021/01/LRTCLHBTCAI6NEOSRJB777NNOU.jpg 1024w, https://www.casino.org/news/wp-content/uploads/2021/01/LRTCLHBTCAI6NEOSRJB777NNOU-142x94.jpg 142w, https://www.casino.org/news/wp-content/uploads/2021/01/LRTCLHBTCAI6NEOSRJB777NNOU-768x509.jpg 768w, https://www.casino.org/news/wp-content/uploads/2021/01/LRTCLHBTCAI6NEOSRJB777NNOU-453x300.jpg 453w" sizes="(max-width: 1200px) 100vw, 1200px"></noscript><figcaption
id="caption-attachment-160868"class=text-description>The lottery balls for Mega Millions jackpot before they are released into the machine for a 2013 drawing. On Tuesday, the Mega Millions jackpot will be worth an estimated $600 million. On Wednesday, Powerball, another multi-state lottery, will hold a drawing for an estimated $550 million prize. (Image: Reuters)</figcaption></figure><p>Tuesday night’s Mega Millions jackpot will be worth an estimated $600 million. That would easily make it the fourth-largest prize in the nearly 19-year history of the game. The cash option will be worth $442.4 million. The last draw took place on Friday, with winning numbers of 3-6-16-18-58 and the &#8220;Mega Ball&#8221; of 11 an unpicked combination.</p><p>On the following night, the Powerball jackpot will be valued at an estimated $550 million. Only eight grand prizes worth more have been awarded in its 29-year history. The cash option for Powerball is $411.4 million. Five people picked Saturday&#8217;s winning numbers of 14-26-38-45-46. However, none of them matched the Powerball of 13 to take home the big prize.</p><p>As the similar jackpot amounts may indicate, both jackpots have not been claimed since both were last hit in the same week. Mega Millions gave out a $95.4 million cash jackpot ($120 million annuity) prize to a Wisconsin man on Sept. 15. The following day, a winning ticket from New York snagged a $75.7 million cash prize ($94.8 million annuity) from Powerball.</p><p>Under the annuity plan for both games, winners would receive an initial amount followed by 29 more annual installments. Those payments would be 5 percent higher each year.</p><h2>Jackpots Have Been This Big at the Same Time Before</h2><p>Could this be the week both jackpots go out? If past trends are any indicator, then it’s quite possible.</p><p>According to the multi-state lotteries, both games reached these levels most recently in October 2018. On Oct. 27, 2018, winning tickets in Iowa and New York split a $687.8 million prize from Powerball. Four days prior to that, an anonymous South Carolina individual took home the biggest Mega Millions prize when they won $1.54 billion.</p><div
class=callout><p>Wednesday also coincides with the five-year anniversary of Powerball’s biggest jackpot. Three tickets,  one each from California, Florida, and Tennessee, split the nearly $1.59 billion annuity. They each took the cash option. That meant they split $983.5 million between them.</p></div><p>While either jackpot has the chance to make even a group of people very rich, it still won’t put anyone in the same orbit as the world’s richest individuals. For perspective, if you win the Mega Millions by yourself and take the cash option, your wealth would be equal to less than one-quarter of 1 percent of <a
href=https://www.casino.org/news/vegas-loop-developer-elon-musk-new-worlds-richest-man-at-190b/ >Elon Musk’s $189.7 billion fortune</a>.</p><p>Both games feature similar concepts that make it easier for jackpots to grow. In Mega Millions, players pick five numbers between 1 and 70, and then a “Mega Ball” numbered 1 to 25 from a separate pool of numbers. In Powerball, the five numbers come from a lot numbered 1 to 69, and then the “Powerball” comes from a separate lot of numbers from 1 to 26.</p><p>The chances of winning the grand prize in Mega Millions is 1 in nearly 302.6 million. For Powerball, it’s 1 in 292.2 million.</p><p>Both games do feature smaller prizes for selecting the correct MegaBall or Powerball. Players who select all five numbers from the first pool of either game win a $1 million prize that also can be increased if they buy the multiplier option. That&#8217;s how a <a
href=https://www.casino.org/news/kentucky-man-plays-lottery-numbers-based-off-movie-claims-2m-powerball-prize/ >Kentucky man won $2 million</a> playing Powerball last month.</p><h2>Lottery Officials Urge Responsible Play</h2><p>Prior to the weekend’s drawings, lottery officials were excited to see customers line up to purchase tickets. But they wanted to ensure players stayed within reasonable limits and their state’s COVID-19 guidelines.</p><blockquote
class=main-blockquote><p>We want our players to have fun, especially when there are two big rolling jackpots to start off the new year,” said Gordon Medenica, Mega Millions lead director and Maryland Lottery and Gaming director, said in a statement on Friday. “While we always encourage responsible play, it’s even more important during these trying times to wear a mask and maintain social distancing when purchasing your tickets.”</p></blockquote><p>Some states allow customers to purchase lottery tickets online. For Mega Millions, that includes Georgia, Illinois, Kentucky, Michigan, New Hampshire, North Carolina, North Dakota, Pennsylvania, and Virginia. Check your local lottery for which states allow online Powerball sales.</p><div
class="wp_rp_wrap  wp_rp_plain" id=wp_rp_first><div
class=wp_rp_content><h3 class="related_post_title">Related News Articles</h3><ul
class="related_post wp_rp"><li
data-position=0 data-poid=in-90755 data-post-type=none ><a
href=https://www.casino.org/news/mega-millions-and-powerball-jackpots-total-1-3billion/ class=wp_rp_thumbnail><img
src=https://www.casino.org/news/wp-content/uploads/2018/10/5bc7af3a61e5f.image_-150x150.jpg alt="Mega Millions and Powerball Jackpots Total $1.3B, Odds of Winning Both: One in 88 Quadrillion" width=150 height=150></a><a
href=https://www.casino.org/news/mega-millions-and-powerball-jackpots-total-1-3billion/ class=wp_rp_title>Mega Millions and Powerball Jackpots Total $1.3B, Odds of Winning Both: One in 88 Quadrillion</a></li><li
data-position=1 data-poid=in-90540 data-post-type=none ><a
href=https://www.casino.org/news/mega-millions-powerball-jackpots-total-999m-for-this-week-drawings/ class=wp_rp_thumbnail><img
src=https://www.casino.org/news/wp-content/uploads/2018/10/5bc52a48e20d6-150x150.jpg alt="Mega Millions, Powerball Jackpots Total $999M for Drawings This Week" width=150 height=150></a><a
href=https://www.casino.org/news/mega-millions-powerball-jackpots-total-999m-for-this-week-drawings/ class=wp_rp_title>Mega Millions, Powerball Jackpots Total $999M for Drawings This Week</a></li><li
data-position=2 data-poid=in-101303 data-post-type=none ><a
href=https://www.casino.org/news/powerball-jackpot-now-estimated-750m-fourth-largest-in-us-history/ class=wp_rp_thumbnail><img
src=https://www.casino.org/news/wp-content/uploads/2019/03/f6814d53-ea34-47e7-b88d-da7f0abeabaf-FullSizeRender_15-150x150.jpg alt="Powerball Jackpot Now Estimated $750M, Fourth-Largest in US History" width=150 height=150></a><a
href=https://www.casino.org/news/powerball-jackpot-now-estimated-750m-fourth-largest-in-us-history/ class=wp_rp_title>Powerball Jackpot Now Estimated $750M, Fourth-Largest in US History</a></li><li
data-position=3 data-poid=in-91269 data-post-type=none ><a
href=https://www.casino.org/news/lottery-hysteria-continues-in-us-powerball-hits-estimated-750m/ class=wp_rp_thumbnail><img
src=https://www.casino.org/news/wp-content/uploads/2018/10/82993a9d-51f7-4c9b-bc08-8a1382df9b1e-EPA_USA_MEGA_MILLIONS_LOTTERY-150x150.jpeg alt="Lottery Hysteria Continues in US, Powerball Hits Estimated $750M" width=150 height=150></a><a
href=https://www.casino.org/news/lottery-hysteria-continues-in-us-powerball-hits-estimated-750m/ class=wp_rp_title>Lottery Hysteria Continues in US, Powerball Hits Estimated $750M</a></li><li
data-position=4 data-poid=in-91137 data-post-type=none ><a
href=https://www.casino.org/news/record-mega-millions-jackpot-won-in-south-carolina/ class=wp_rp_thumbnail><img
src=https://www.casino.org/news/wp-content/uploads/2018/10/7e703a08db2aed8bab5b3c229374ee96-150x150.jpg alt="Record $1.53B Mega Millions Jackpot Won in South Carolina, Person Can Remain Anonymous" width=150 height=150></a><a
href=https://www.casino.org/news/record-mega-millions-jackpot-won-in-south-carolina/ class=wp_rp_title>Record $1.53B Mega Millions Jackpot Won in South Carolina, Person Can Remain Anonymous</a></li></ul></div></div></div></div><aside
class=sidebar><h3 class="main-title main-title--sm">Most Popular</h3><div
class="flex-row flex-row--flex-start last-post-border-none"><div
class=col><div
class="blog-post-item
blog-post-item--vertical
blog-post-item--sm-horizontal
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/hard-rock-reportedly-interested-venetian-and-palazzo/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2021/01/download-120x120.jpg
alt="Hard Rock Venetian Palazzo Las Vegas"
data-image-id=160207
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2021/01/download-120x120.jpg
alt="Hard Rock Venetian Palazzo Las Vegas">
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/hard-rock-reportedly-interested-venetian-and-palazzo/ >
Hard Rock International Reportedly Interested in Sands&#8217; Venetian and Palazzo </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/devin-oconnor/ >Devin O'Connor</a>
</span>
— <span
class=blog-post-item__date>January 4, 2021</span></div></div></div></div><div
class=col><div
class="blog-post-item
blog-post-item--vertical
blog-post-item--sm-horizontal
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/majestic-las-vegas-groundbreaking-scheduled-for-july-at-former-clarion-hotel-site/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2021/01/clarion-2015-KTNV-120x120.jpg
alt
data-image-id=160231
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2021/01/clarion-2015-KTNV-120x120.jpg
alt>
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/majestic-las-vegas-groundbreaking-scheduled-for-july-at-former-clarion-hotel-site/ >
Majestic Las Vegas Groundbreaking Scheduled for July at Former Clarion Hotel Site </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/ed-silverstein/ >Ed Silverstein</a>
</span>
— <span
class=blog-post-item__date>January 4, 2021</span></div></div></div></div><div
class=col><div
class="blog-post-item
blog-post-item--vertical
blog-post-item--sm-horizontal
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/sheldon-adelson-and-james-packer-spend-new-years-together/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2021/01/collage-120x120.jpg
alt="Sheldon Adelson James Packer casino"
data-image-id=160077
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2021/01/collage-120x120.jpg
alt="Sheldon Adelson James Packer casino">
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/sheldon-adelson-and-james-packer-spend-new-years-together/ >
Sheldon Adelson, James Packer Huddle For New Year&#8217;s &#8211; Sands/Crown Deal Forthcoming? </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/devin-oconnor/ >Devin O'Connor</a>
</span>
— <span
class=blog-post-item__date>January 2, 2021</span></div></div></div></div></div><nav
class=side-nav><h3 class="main-title main-title--sm">Latest Casino News</h3><ul
class=side-nav__list><li
class=side-nav__item><a
href=https://www.casino.org/news/financial/  title=Financial>Financial</a></li><li
class=side-nav__item><a
href=https://www.casino.org/news/legislation/  title=Legislation>Legislation</a></li><li
class=side-nav__item><a
href=https://www.casino.org/news/tournaments/  title="Poker Tournaments">Poker Tournaments</a></li><li
class=side-nav__item><a
href=https://www.casino.org/news/players/  title="Famous Players">Famous Players</a></li><li
class=side-nav__item><a
href=https://www.casino.org/news/sports/  title=Sports>Sports</a></li><li
class=side-nav__item><a
href=https://www.casino.org/news/mobile-gaming/  title="Mobile Gaming">Mobile Gaming</a></li><li
class=side-nav__item><a
href=https://www.casino.org/news/rumors/  title=Rumors>Rumors</a></li><li
class=side-nav__item><a
href=https://www.casino.org/news/internet-gaming/  title="Internet Gaming">Internet Gaming</a></li><li
class=side-nav__item><a
href=https://www.casino.org/news/scandals/  title=Scandals>Scandals</a></li><li
class=side-nav__item><a
href=https://www.casino.org/news/live-casinos/  title="Live Casinos">Live Casinos</a></li><li
class=side-nav__item><a
href=/blog/  title=Features>Features</a></li><div
class="side-nav__submenu__holder js-submenu-holder"><a
href=# class="btn btn--arrow btn--arrow-right js-submenu-opener">More from Casino.org</a><ul
class="side-nav__list side-nav__list--submenu"><li
class="side-nav__item side-nav__item--submenu"><a
href=/about/  title="About Casino.org">About Casino.org</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/  title=Home>Home</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/faq/  title=FAQ>FAQ</a></li><li
class="side-nav__item side-nav__item--submenu"><span>Guides</span></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/mobile/  title=Mobile>Mobile</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/reviews/  title=Reviews>Reviews</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/games/free/  title="Free Games">Free Games</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/real-money/  title="Real Money">Real Money</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/local/  title="Local Casino Finder">Local Casino Finder</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/local/guide/  title="Local Guide">Local Guide</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/iphone/  title=iPhone>iPhone</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/android/  title=Android>Android</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/gambling/  title="Gambling Guide">Gambling Guide</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/slots/  title=Slots>Slots</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/roulette/  title=Roulette>Roulette</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/blackjack/  title=Blackjack>Blackjack</a></li><li
class="side-nav__item side-nav__item--submenu"><span>Country Guides</span></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/uk/  title=UK>UK</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/canada/  title=Canada>Canada</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/india/  title=India>India</a></li><li
class="side-nav__item side-nav__item--submenu side-nav__item--indented"><a
href=/new-zealand/  title="New Zealand">New Zealand</a></li></ul></ul></nav><div
class=cta-banner><h2 class="cta-banner__title">
Got a tip for our reporters?</h2>
<a
href=mailto:newseditor@casino.org class=cta-banner__link>
Get in Touch </a></div></aside></div></div></section><section
class=post-comments><div
class=container><div
class=post-comments__content><section
id=comments class=post-comments><div
class=container><div
class=post-comments__content><h2 class="post-comments__content-title">
No comments yet</h2><div
class="comments-form js-open-close-form">
<a
href=# class="post-comments__link js-opener-form">Write a comment</a><div
class=comment><div
id=respond class=comment-respond><h3 id="reply-title" class="comment-reply-title">Write a comment <small><a
rel=nofollow id=cancel-comment-reply-link href=/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week/#respond style=display:none;>Cancel reply</a></small></h3><form
action=https://www.casino.org/news/wp-comments-post.php method=post id=commentform class=comment-form><p
class=comment-notes><span
id=email-notes>Your email address will not be published.</span></p><p
class=comment-form-cookies-consent><input
id=wp-comment-cookies-consent name=wp-comment-cookies-consent type=checkbox value=yes  required aria-required=true><label
for=wp-comment-cookies-consent class="comment-cookies is-cookies">Name, email and comment will be stored in our database.</label></p><p
class=comment-form-comment> <label
for=comment>Comment <span
class=required>*</span></label><textarea id=comment placeholder=Comment name=comment cols=45 rows=8 maxlength=65525 required=required></textarea></p><p
class=comment-form-author><label
for=author>Name <span
class=required>*</span></label> <input
id=author name=author type=text placeholder=Name value size=30 maxlength=245  required aria-required=true></p><p
class=comment-form-email><label
for=email>Email <span
class=required>*</span></label> <input
id=email name=email  placeholder=Email value size=30 maxlength=100 aria-describedby=email-notes   type=email  required aria-required=true></p><p
class=form-submit><input
name=submit type=submit id=submit class=submit value="Post Comment"> <input
type=hidden name=comment_post_ID value=160867 id=comment_post_ID>
<input
type=hidden name=comment_parent id=comment_parent value=0></p><p
style="display: none;"><input
type=hidden id=akismet_comment_nonce name=akismet_comment_nonce value=2571ca0600></p><p
style="display: none;"><input
type=hidden id=ak_js name=ak_js value=235></p></form></div></div></div></div></div></section></div></div></section><section
class=content-section><div
class=container><h2 class="main-title">
Related News Articles</h2><div
class=articles-holder><div
class=wrapper-posts><div
class="flex-row flex-row--multiple"><div
class="col col--tablet-4"><div
class="blog-post-item
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/mega-millions-and-powerball-jackpots-total-1-3billion/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2018/10/5bc7af3a61e5f.image_-453x300.jpg
alt="Mega Millions Powerball lottery jackpot"
data-image-id=90760
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2018/10/5bc7af3a61e5f.image_-453x300.jpg
alt="Mega Millions Powerball lottery jackpot">
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/mega-millions-and-powerball-jackpots-total-1-3billion/ >
Mega Millions and Powerball Jackpots Total $1.3B, Odds of Winning Both: One in 88 Quadrillion </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/devin-oconnor/ >Devin O'Connor</a>
</span>
— <span
class=blog-post-item__date>October 18, 2018</span></div></div></div></div><div
class="col col--tablet-4"><div
class="blog-post-item
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/mega-millions-powerball-jackpots-total-999m-for-this-week-drawings/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2018/10/5bc52a48e20d6-453x300.jpg
alt="Mega Millions Powerball jackpot lottery"
data-image-id=90545
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2018/10/5bc52a48e20d6-453x300.jpg
alt="Mega Millions Powerball jackpot lottery">
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/mega-millions-powerball-jackpots-total-999m-for-this-week-drawings/ >
Mega Millions, Powerball Jackpots Total $999M for Drawings This Week </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/devin-oconnor/ >Devin O'Connor</a>
</span>
— <span
class=blog-post-item__date>October 16, 2018</span></div></div></div></div><div
class="col col--tablet-4"><div
class="blog-post-item
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/powerball-jackpot-now-estimated-750m-fourth-largest-in-us-history/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2019/03/f6814d53-ea34-47e7-b88d-da7f0abeabaf-FullSizeRender_15.jpg
alt="Powerball jackpot lottery odds Mega Millions"
data-image-id=101307
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2019/03/f6814d53-ea34-47e7-b88d-da7f0abeabaf-FullSizeRender_15.jpg
alt="Powerball jackpot lottery odds Mega Millions">
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/powerball-jackpot-now-estimated-750m-fourth-largest-in-us-history/ >
Powerball Jackpot Now Estimated $750M, Fourth-Largest in US History </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/devin-oconnor/ >Devin O'Connor</a>
</span>
— <span
class=blog-post-item__date>March 25, 2019</span></div></div></div></div><div
class="col col--tablet-4"><div
class="blog-post-item
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/lottery-hysteria-continues-in-us-powerball-hits-estimated-750m/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2018/10/82993a9d-51f7-4c9b-bc08-8a1382df9b1e-EPA_USA_MEGA_MILLIONS_LOTTERY-453x300.jpeg
alt="lottery Powerball jackpot Mega Millions"
data-image-id=91280
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2018/10/82993a9d-51f7-4c9b-bc08-8a1382df9b1e-EPA_USA_MEGA_MILLIONS_LOTTERY-453x300.jpeg
alt="lottery Powerball jackpot Mega Millions">
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/lottery-hysteria-continues-in-us-powerball-hits-estimated-750m/ >
Lottery Hysteria Continues in US, Powerball Hits Estimated $750M </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/devin-oconnor/ >Devin O'Connor</a>
</span>
— <span
class=blog-post-item__date>October 25, 2018</span></div></div></div></div></div></div></div></div></section><section
class=content-section><div
class=container><div
class="flex-row flex-row--flex-start flex-row--direction last-post-border-none"><div
class="col col--desktop-4"><div
class=mobile-gray-section><h3 class="main-title main-title--sm">Most Popular</h3><div
class="flex-row flex-row--flex-start last-post-border-none
"><div
class="col
"><div
class="blog-post-item
blog-post-item--vertical
blog-post-item--sm-horizontal
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/bellagio-fountains-new-years-crowd-size-may-be-coronavirus-superspreader-social-media-warns/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2021/01/Bellagio-120x120.jpg
alt
data-image-id=160046
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2021/01/Bellagio-120x120.jpg
alt>
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/bellagio-fountains-new-years-crowd-size-may-be-coronavirus-superspreader-social-media-warns/ >
Bellagio Fountains New Year’s Crowd Size May Be Coronavirus Superspreader, Social Media Warns </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/ed-silverstein/ >Ed Silverstein</a>
</span>
— <span
class=blog-post-item__date>January 1, 2021</span></div></div></div></div><div
class="col
"><div
class="blog-post-item
blog-post-item--vertical
blog-post-item--sm-horizontal
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/landcadia-investors-finally-approve-gnog-merger/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2020/12/tilman-3-120x120.jpg
alt="Landcadia GNOG"
data-image-id=159809
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2020/12/tilman-3-120x120.jpg
alt="Landcadia GNOG">
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/landcadia-investors-finally-approve-gnog-merger/ >
Golden Nugget Online To Make Nasdaq Debut After Landcadia Holders Approve Merger </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/todd-shriber/ >Todd Shriber</a>
</span>
— <span
class=blog-post-item__date>December 29, 2020</span></div></div></div></div><div
class="col
"><div
class="blog-post-item
blog-post-item--vertical
blog-post-item--sm-horizontal
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/vegas-loop-developer-elon-musk-new-worlds-richest-man-at-190b/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2021/01/191228103741-01-elon-musk-file-120x120.jpg
alt
data-image-id=160831
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2021/01/191228103741-01-elon-musk-file-120x120.jpg
alt>
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/vegas-loop-developer-elon-musk-new-worlds-richest-man-at-190b/ >
Elon Musk New World&#8217;s Richest Man at $190B, as Las Vegas May Help Him Make More Money </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/steve-bittenbender/ >Steve Bittenbender</a>
</span>
— <span
class=blog-post-item__date>January 9, 2021</span></div></div></div></div><div
class="col
"><div
class="blog-post-item
blog-post-item--vertical
blog-post-item--sm-horizontal
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/las-vegas-era-from-movie-casino-gone-forever-former-mobster/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2021/01/Cullotta-120x120.png
alt
data-image-id=160856
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2021/01/Cullotta-120x120.png
alt>
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/las-vegas-era-from-movie-casino-gone-forever-former-mobster/ >
Las Vegas Era From Movie ‘Casino’ Gone Forever: Former Mobster </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/larry-henry/ >Larry Henry</a>
</span>
— <span
class=blog-post-item__date>January 10, 2021</span></div></div></div></div><div
class="col
"><div
class="blog-post-item
blog-post-item--vertical
blog-post-item--sm-horizontal
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/rsi-stock-quickly-gets-price-target-boost-on-first-trading-day/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2020/12/bull-120x120.jpg
alt="RSI stock"
data-image-id=159954
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2020/12/bull-120x120.jpg
alt="RSI stock">
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/rsi-stock-quickly-gets-price-target-boost-on-first-trading-day/ >
Rush Street Interactive Lands Price Target Hike on First Day of Trading </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/todd-shriber/ >Todd Shriber</a>
</span>
— <span
class=blog-post-item__date>December 31, 2020</span></div></div></div></div></div></div></div><div
class="col col--desktop-2"><h3 class="main-title main-title--sm">Most Commented</h3><ul
class=counter-blog><li
class=counter-blog__item><div
class="blog-post-item
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/las-vegas-casinos-can-restore-magic-of-earlier-era-by-reconnecting-with-customers-gaming-expert/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2020/12/Sands-implosion-453x300.jpeg
alt
data-image-id=157572
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2020/12/Sands-implosion-453x300.jpeg
alt>
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/las-vegas-casinos-can-restore-magic-of-earlier-era-by-reconnecting-with-customers-gaming-expert/ >
Las Vegas Casinos Can Restore Magic of Earlier Era by Reconnecting With Customers: Gaming Expert </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/larry-henry/ >Larry Henry</a>
</span>
— <span
class=blog-post-item__date>December 6, 2020</span>
— <span
class=blog-post-item__date><a
href=https://www.casino.org/news/las-vegas-casinos-can-restore-magic-of-earlier-era-by-reconnecting-with-customers-gaming-expert/#comments>36 Comments</a></span></div></div></div></li><li
class=counter-blog__item><div
class="blog-post-item
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/hard-rock-reportedly-interested-venetian-and-palazzo/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2021/01/download-453x300.jpg
alt="Hard Rock Venetian Palazzo Las Vegas"
data-image-id=160207
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2021/01/download-453x300.jpg
alt="Hard Rock Venetian Palazzo Las Vegas">
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/hard-rock-reportedly-interested-venetian-and-palazzo/ >
Hard Rock International Reportedly Interested in Sands&#8217; Venetian and Palazzo </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/devin-oconnor/ >Devin O'Connor</a>
</span>
— <span
class=blog-post-item__date>January 4, 2021</span>
— <span
class=blog-post-item__date><a
href=https://www.casino.org/news/hard-rock-reportedly-interested-venetian-and-palazzo/#comments>17 Comments</a></span></div></div></div></li><li
class=counter-blog__item><div
class="blog-post-item
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/landcadia-shareholder-meeting-more-investors-need-to-vote-gnog-deal/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2020/12/tilman-1-453x300.jpg
alt="Landcadia Meeting"
data-image-id=159010
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2020/12/tilman-1-453x300.jpg
alt="Landcadia Meeting">
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/landcadia-shareholder-meeting-more-investors-need-to-vote-gnog-deal/ >
Landcadia Investor Votes Needed to Expedite Golden Nugget Online Merger </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/todd-shriber/ >Todd Shriber</a>
</span>
— <span
class=blog-post-item__date>December 18, 2020</span>
— <span
class=blog-post-item__date><a
href=https://www.casino.org/news/landcadia-shareholder-meeting-more-investors-need-to-vote-gnog-deal/#comments>11 Comments</a></span></div></div></div></li><li
class=counter-blog__item><div
class="blog-post-item
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/bellagio-fountains-new-years-crowd-size-may-be-coronavirus-superspreader-social-media-warns/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2021/01/Bellagio-453x300.jpg
alt
data-image-id=160046
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2021/01/Bellagio-453x300.jpg
alt>
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/bellagio-fountains-new-years-crowd-size-may-be-coronavirus-superspreader-social-media-warns/ >
Bellagio Fountains New Year’s Crowd Size May Be Coronavirus Superspreader, Social Media Warns </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/ed-silverstein/ >Ed Silverstein</a>
</span>
— <span
class=blog-post-item__date>January 1, 2021</span>
— <span
class=blog-post-item__date><a
href=https://www.casino.org/news/bellagio-fountains-new-years-crowd-size-may-be-coronavirus-superspreader-social-media-warns/#comments>6 Comments</a></span></div></div></div></li><li
class=counter-blog__item><div
class="blog-post-item
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/mgm-resorts-offering-las-vegas-guests-on-demand-fuel-delivery/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2020/12/mandalay_039_34713306245_o-900x600-1-453x300.jpg
alt="MGM Resorts parking Las Vegas"
data-image-id=158725
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2020/12/mandalay_039_34713306245_o-900x600-1-453x300.jpg
alt="MGM Resorts parking Las Vegas">
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/mgm-resorts-offering-las-vegas-guests-on-demand-fuel-delivery/ >
MGM Resorts Offering Las Vegas Guests On-Demand Mobile Fuel Delivery Service </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/devin-oconnor/ >Devin O'Connor</a>
</span>
— <span
class=blog-post-item__date>December 16, 2020</span>
— <span
class=blog-post-item__date><a
href=https://www.casino.org/news/mgm-resorts-offering-las-vegas-guests-on-demand-fuel-delivery/#comments>6 Comments</a></span></div></div></div></li></ul></div><div
class="col col--desktop-4"><h3 class="main-title main-title--sm">Most Read</h3><div
class="flex-row flex-row--flex-start last-post-border-none
"><div
class="col
col--mobile-tablet-2        "><div
class="blog-post-item
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/rush-street-interactive-goes-public-following-merger-with-spac/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2020/12/rsi-453x300.jpg
alt="Rush Street"
data-image-id=159866
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2020/12/rsi-453x300.jpg
alt="Rush Street">
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/rush-street-interactive-goes-public-following-merger-with-spac/ >
Rush Street Interactive Debuts on New York Stock Exchange Following SPAC Deal </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/todd-shriber/ >Todd Shriber</a>
</span>
— <span
class=blog-post-item__date>December 30, 2020</span></div></div></div></div><div
class="col
col--mobile-tablet-2        "><div
class="blog-post-item
"><div
class=blog-post-item__image-holder>
<a
href=https://www.casino.org/news/mgm-resorts-is-entertaining-a-takeover-of-betmgm-partner-entain/ >
<img
src=/assets/media/images/common/transparent_3x2.gif
data-src=https://www.casino.org/news/wp-content/uploads/2021/01/betmgm-453x300.jpeg
alt="MGM Entain"
data-image-id=160110
class=lazyload><noscript>
<img
src=https://www.casino.org/news/wp-content/uploads/2021/01/betmgm-453x300.jpeg
alt="MGM Entain">
</noscript>
</a></div><div
class=blog-post-item__content-holder><h4 class="blog-post-item__title
">
<a
href=https://www.casino.org/news/mgm-resorts-is-entertaining-a-takeover-of-betmgm-partner-entain/ >
MGM Resorts Reportedly Makes Offer for Entain, Aims for Full Control of Sports Betting Business </a></h4><div
class=blog-post-item__date-holder>
<span
class=blog-post-item__author>
<a
href=https://www.casino.org/news/author/todd-shriber/ >Todd Shriber</a>
</span>
— <span
class=blog-post-item__date>January 3, 2021</span></div></div></div></div></div></div></div></div></section></main><footer
class=footer><div
class="footer__container container"><div
class=about-us-footer>
<a
href=/ class=footer__logo-link>
<img
src=/assets/media/images/common/transparent_3x2.gif data-src=/assets/media/images/global/logo/25year/logo-casino-org-25years-no-trademark.svg alt=Casino.org class="footer__logo-image lazyload">
</a><p>
Casino.org is the world’s leading independent online gaming authority, providing trusted online casino
news, guides, reviews and information since 1995.</p></div><div
class=footer-quick-links><nav
class=footer-quick-links__nav><ul
class=footer-quick-links__list><li
class=footer-quick-links__item><a
class=footer-quick-links__link href=/contact/ >Contact Us</a></li><li
class=footer-quick-links__item><a
class=footer-quick-links__link href=/get-listed/ >Get Listed</a></li><li
class=footer-quick-links__item><a
class=footer-quick-links__link href=/about/ >About Us</a></li><li
class=footer-quick-links__item><a
class=footer-quick-links__link href=/meet-the-team/ >Meet the Team</a></li><li
class=footer-quick-links__item><a
class=footer-quick-links__link href=https://www.casino.org/news/editorial-guidelines/ >Editorial Guidelines</a></li><li
class=footer-quick-links__item><a
class=footer-quick-links__link href=/careers/ >Careers</a></li></ul></nav><div
class="footer-selection js-open-close">
<span
class="footer-selection__opener js-opener">
More News </span><div
class=footer-selection__drop-holder><nav
class=footer-selection__drop><ul
class=footer-selection__list><li
class=footer-selection__list-item>
<a
class=footer-selection__link href=https://www.casino.org/news/las-vegas-hotel-room-rates-plunge-with-no-in-person-ces-event-this-year/ > Las Vegas Hotel Room Rates Plunge With No In-Person CES Event This Year</a></li><li
class=footer-selection__list-item>
<a
class=footer-selection__link href=https://www.casino.org/news/entain-ceo-shay-segev-quits-amid-11-billion-mgm-takeover-talks/ > Entain CEO Shay Segev Quits Amid $11 Billion MGM Takeover Talks</a></li><li
class=footer-selection__list-item>
<a
class=footer-selection__link href=https://www.casino.org/news/trump-impeachment-odds-shorten-as-president-continues-to-lose-allies/ > Trump Impeachment Odds Shorten, as President Continues to Lose Allies</a></li><li
class=footer-selection__list-item>
<a
class=footer-selection__link href=https://www.casino.org/news/wakayama-officials-say-integrated-resort-casino-focus-on-wellness/ > Wakayama Officials Say Integrated Resort Casino Must Focus on Wellness and Nature</a></li><li
class=footer-selection__list-item>
<a
class=footer-selection__link href=https://www.casino.org/news/flutter-preferred-betting-stock-over-draftkings-says-fund-manager/ > Flutter, not DraftKings, Is Preferred Sports Wagering Equity Bet, Says Fund Manager</a></li></ul></nav></div></div><div
class="footer-selection js-open-close">
<span
class="footer-selection__opener js-opener">
More from Casino.org </span><div
class=footer-selection__drop-holder><nav
class=footer-selection__drop><div
class=footer-selection__block><h4 class="footer-selection__title"><a
href=/about/
class="footer-selection__link footer-selection__link--title"
title="About Casino.org">About Casino.org</a></h4><ul
class="footer-selection__list footer-selection__list--inner"><li
class=footer-selection__item><a
class=footer-selection__link href=/ title=Home>Home</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/blog/ title="Casino.org Blog">Casino.org Blog</a></li></ul></div><div
class=footer-selection__block><h4 class="footer-selection__title">Casino Guides</h4><ul
class="footer-selection__list footer-selection__list--inner"><li
class=footer-selection__item><a
class=footer-selection__link href=/real-money/ title="Best Online Casinos">Best Online Casinos</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/gambling/ title="Online Gambling Sites">Online Gambling Sites</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/bonus/ title="Online Casino Bonuses">Online Casino Bonuses</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/bonus/no-deposit/ title="No Deposit Bonuses">No Deposit Bonuses</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/bonus/free-spins/ title="Free Spins Casinos">Free Spins Casinos</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/reviews/ title="Casino Reviews">Casino Reviews</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/games/ title="Online Casino Games">Online Casino Games</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/slots/ title="Online Slots">Online Slots</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/progressive-jackpots/ title="Progressive Jackpot Slots">Progressive Jackpot Slots</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/roulette/ title="Online Roulette">Online Roulette</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/blackjack/ title="Online Blackjack">Online Blackjack</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/video-poker/ title="Video Poker">Video Poker</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/poker/ title="Online Poker">Online Poker</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/games/free/ title="Free Casino Games">Free Casino Games</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/mobile/ title="Mobile Casinos">Mobile Casinos</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/android/ title="Android Casinos">Android Casinos</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/iphone/ title="iPhone Casinos">iPhone Casinos</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/local/ title="Local Casino Finder">Local Casino Finder</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/local/guide/ title="Guide to US Gambling Ages">Guide to US Gambling Ages</a></li></ul></div><div
class=footer-selection__block><h4 class="footer-selection__title">Country Casino Guides</h4><ul
class="footer-selection__list footer-selection__list--inner"><li
class=footer-selection__item><a
class=footer-selection__link href=/uk/ title=UK>UK</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/canada/ title=Canada>Canada</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/india/ title=India>India</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/new-zealand/ title="New Zealand">New Zealand</a></li><li
class=footer-selection__item><a
class=footer-selection__link href=/world/ title="Worldwide Online Casinos">Worldwide Online Casinos</a></li></ul ></div ></nav></div></div><div
class="footer-selection js-open-close">
<span
class="footer-selection__opener js-opener">
Select Country </span><div
class="footer-selection__drop-holder is-short"><nav
class=footer-selection__drop><div
class=footer-selection__block><h4 class="footer-selection__title"><a
href=/arabic/
class="footer-selection__link footer-selection__link--title"
title=Arabic>Arabic</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/argentina/
class="footer-selection__link footer-selection__link--title"
title=Argentina>Argentina</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/brasil/
class="footer-selection__link footer-selection__link--title"
title=Brasil>Brasil</a></h4><h4 class="footer-selection__title"><a
href=/bulgariya/
class="footer-selection__link footer-selection__link--title"
title=Bulgariya>Bulgariya</a></h4><h4 class="footer-selection__title"><a
href=/canada/
class="footer-selection__link footer-selection__link--title"
title=Canada>Canada</a></h4><h4 class="footer-selection__title"><a
href=/canada/fr/
class="footer-selection__link footer-selection__link--title"
title="Canada Français">Canada Français</a></h4><h4 class="footer-selection__title"><a
href=/chile/
class="footer-selection__link footer-selection__link--title"
title=Chile>Chile</a></h4><h4 class="footer-selection__title"><a
href=/croatia/
class="footer-selection__link footer-selection__link--title"
title=Croatia>Croatia</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/de/
class="footer-selection__link footer-selection__link--title"
title=Deutschland>Deutschland</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/es/
class="footer-selection__link footer-selection__link--title"
title=España>España</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/fr/
class="footer-selection__link footer-selection__link--title"
title=Français>Français</a></h4><h4 class="footer-selection__title"><a
href=/india/
class="footer-selection__link footer-selection__link--title"
title=India>India</a></h4><h4 class="footer-selection__title"><a
href=/india/hindi/
class="footer-selection__link footer-selection__link--title"
title="India (Hindi)">India (Hindi)</a></h4><h4 class="footer-selection__title"><a
href=/indonesia/
class="footer-selection__link footer-selection__link--title"
title=Indonesia>Indonesia</a></h4><h4 class="footer-selection__title"><a
href=/ireland/
class="footer-selection__link footer-selection__link--title"
title=Ireland>Ireland</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/it/
class="footer-selection__link footer-selection__link--title"
title=Italia>Italia</a></h4><h4 class="footer-selection__title"><a
href=/kenya/
class="footer-selection__link footer-selection__link--title"
title=Kenya>Kenya</a></h4><h4 class="footer-selection__title"><a
href=/macau/
class="footer-selection__link footer-selection__link--title"
title=Macau>Macau</a></h4><h4 class="footer-selection__title"><a
href=/mexico/
class="footer-selection__link footer-selection__link--title"
title=México>México</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/nl/
class="footer-selection__link footer-selection__link--title"
title=Nederland>Nederland</a></h4><h4 class="footer-selection__title"><a
href=/new-zealand/
class="footer-selection__link footer-selection__link--title"
title="New Zealand">New Zealand</a></h4><h4 class="footer-selection__title"><a
href=/nigeria/
class="footer-selection__link footer-selection__link--title"
title=Nigeria>Nigeria</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/no/
class="footer-selection__link footer-selection__link--title"
title=Norge>Norge</a></h4><h4 class="footer-selection__title"><a
href=/canada/quebec/
class="footer-selection__link footer-selection__link--title"
title=Québec>Québec</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/osterreich/
class="footer-selection__link footer-selection__link--title"
title=Österreich>Österreich</a></h4><h4 class="footer-selection__title"><a
href=/panama/
class="footer-selection__link footer-selection__link--title"
title=Panama>Panama</a></h4><h4 class="footer-selection__title"><a
href=/paraguay/
class="footer-selection__link footer-selection__link--title"
title=Paraguay>Paraguay</a></h4><h4 class="footer-selection__title"><a
href=/polska/
class="footer-selection__link footer-selection__link--title"
title=Polska>Polska</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/pt/
class="footer-selection__link footer-selection__link--title"
title=Português>Português</a></h4><h4 class="footer-selection__title"><a
href=/romania/
class="footer-selection__link footer-selection__link--title"
title=Romania>Romania</a></h4><h4 class="footer-selection__title"><a
href=/serbia/
class="footer-selection__link footer-selection__link--title"
title=Serbia>Serbia</a></h4><h4 class="footer-selection__title"><a
href=/slovakia/
class="footer-selection__link footer-selection__link--title"
title=Slovakia>Slovakia</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/schweiz/
class="footer-selection__link footer-selection__link--title"
title=Schweiz>Schweiz</a></h4><h4 class="footer-selection__title"><a
href=/sri-lanka/
class="footer-selection__link footer-selection__link--title"
title=Sri-lanka>Sri-lanka</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/suisse/
class="footer-selection__link footer-selection__link--title"
title=Suisse>Suisse</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/fi/
class="footer-selection__link footer-selection__link--title"
title=Suomi>Suomi</a></h4><h4 class="footer-selection__title"><a
href=https://www.casino.org/sv/
class="footer-selection__link footer-selection__link--title"
title=Sverige>Sverige</a></h4><h4 class="footer-selection__title"><a
href=/svizzera/
class="footer-selection__link footer-selection__link--title"
title=Svizzera>Svizzera</a></h4><h4 class="footer-selection__title"><a
href=/south-africa/
class="footer-selection__link footer-selection__link--title"
title="South Africa">South Africa</a></h4><h4 class="footer-selection__title"><a
href=/uganda/
class="footer-selection__link footer-selection__link--title"
title=Uganda>Uganda</a></h4><h4 class="footer-selection__title"><a
href=/uk/
class="footer-selection__link footer-selection__link--title"
title="United Kingdom">United Kingdom</a></h4><h4 class="footer-selection__title"><a
href=/ukraine/
class="footer-selection__link footer-selection__link--title"
title=Ukraine>Ukraine</a></h4><h4 class="footer-selection__title"><a
href=/uruguay/
class="footer-selection__link footer-selection__link--title"
title=Uruguay>Uruguay</a></h4><h4 class="footer-selection__title"><a
href=/vietnam/
class="footer-selection__link footer-selection__link--title"
title=Vietnam>Vietnam</a></h4></div ></nav></div></div><div
class=follow-links>
<span
class=follow-links__title>Follow us:</span><ul
class=social-list><li
class=social-list__item>
<a
href=https://twitter.com/Casino_Org class="social-list__link social-list__link--white icon-twitter" ref="nofollow noopener noreferrer" target=_blank></a></li><li
class=social-list__item>
<a
href=https://www.facebook.com/Casino.OrgNews/ class="social-list__link social-list__link--white icon-facebook" ref="nofollow noopener noreferrer" target=_blank></a></li><li
class=social-list__item>
<a
href=https://www.youtube.com/channel/UCgkYZZbmwKbCl1E41pMDWng class="social-list__link social-list__link--white icon-youtube" ref="nofollow noopener noreferrer" target=_blank></a></li></ul></div></div><ul
class=privacy-row><li><a
class=privacy-row__link href=/ >Home</a></li><li><a
class=privacy-row__link href=/terms-of-service/ >Terms of Service</a></li><li><a
class=privacy-row__link href=/privacy-policy/ >Privacy Policy</a></li><li><a
class=privacy-row__link href=/sitemap/ >Sitemap</a></li><li><a
class=privacy-row__link href=/gambling-addiction/ >Problem Gambling</a></li></ul></div><div
class=bottom-panel-footer><div
class="bottom-panel-footer__container container"><div
class=bottom-panel-footer__certificate>
<span
class=bottom-panel-footer__title><b>Casino.org</b> website is certified by: </span><div
class=bottom-panel-footer__logos><div
class=bottom-panel-footer__logo-holder>
<img
class=lazyload src=/assets/media/images/common/transparent_3x2.gif data-src=/assets/media/images/global/footer/logo--truste.png alt="TRUSTe logo">
<noscript>
<img
src=/assets/media/images/global/footer/logo--truste.png alt="TRUSTe logo">
</noscript></div><div
class=bottom-panel-footer__logo-holder>
<a
rel="noopener noreferrer" href="//www.dmca.com/Protection/Status.aspx?ID=3b12d0cf-e6a4-46ab-a701-e3dc4148f8c1&amp;refurl=https://www.casino.org/news/600m-mega-millions-550m-powerball-jackpots-up-for-grabs-this-week" target=_blank>
<img
class=lazyload src=/assets/media/images/common/transparent_3x2.gif data-src=/assets/media/images/global/footer/logo--dmca.png alt="DMCA.com Protection Status">
<noscript>
<img
src=/assets/media/images/global/footer/logo--dmca.png alt="DMCA.com Protection Status">
</noscript>
</a></div><div
class=bottom-panel-footer__logo-holder>
<img
class="bottom-panel-footer__logo--lg lazyload" src=/assets/media/images/common/transparent_3x2.gif data-src=/assets/media/images/global/footer/logo--norton.png alt="Norton logo">
<noscript>
<img
src=/assets/media/images/global/footer/logo--norton.png alt="Norton logo">
</noscript></div><div
class=bottom-panel-footer__logo-holder>
<img
class=lazyload src=/assets/media/images/common/transparent_3x2.gif data-src=/assets/media/images/global/footer/logo--sucun.png alt="SUCUN logo">
<noscript>
<img
src=/assets/media/images/global/footer/logo--sucun.png alt="SUCUN logo">
</noscript></div></div></div><div
class=bottom-panel-footer__copyright>
<span>Copyright © 1995-2021, <b><a
href=/ class=bottom-panel-footer__copy-link>Casino.org</a>, </b></span>
<span>All Rights Reserved</span></div></div></div></footer></div> <script src='https://www.casino.org/news/wp-includes/js/wp-embed.min.js?x27667'></script> <script async=async src='https://www.casino.org/news/wp-content/plugins/akismet/_inc/form.js?x27667'></script> <script src=/assets/js/vendors.8e26eebd6fd1d3f255c9.js></script><script src=/assets/js/WP-Hendrix-Theme-global.0195155d3099ffefaa87.js></script> <script>'use strict';

    //Xtreme Push SDK
    (function(p,u,s,h,e,r,l,i,b) {p['XtremePushObject']=s;p[s]=function(){
        (p[s].q=p[s].q||[]).push(arguments)};i=u.createElement('script');i.async=1;
        i.src=h;b=u.getElementsByTagName('script')[0];b.parentNode.insertBefore(i,b);
    })(window,document,'xtremepush','https://prod.webpu.sh/gAewN86ixJocdplRP-vNSz8riz8pf2ip/sdk.js');

    function loadCSS(href) {
        var ss = window.document.createElement('link'),
            ref = window.document.getElementsByTagName('head')[0];
        ss.rel = 'stylesheet';
        ss.href = href;

        ss.media = 'only x';
        ref.append(ss);
        setTimeout(function () {
            ss.media = 'all';
        }, 0);
    }

        loadCSS("/assets/css/wp-news__hendrix-71a1841fa3.css");</script> <noscript><link
rel=stylesheet href=/assets/css/wp-news__hendrix-71a1841fa3.css>
</noscript> <script>var sa_custom = sa_custom || {};
    sa_custom.visitor_consent = 1;
    var sa_site_ids = sa_site_ids || [];
    sa_site_ids.push(232375);
    (function () {
        var s = document.createElement('script');
        s.type = 'text/javascript';
        s.async = true;
        s.src = '//sa.casino.org/js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(s);
    })();</script> <noscript><p><img
alt width=1 height=1 src=//sa.casino.org/232375ns.gif></p></noscript> <script defer src=/assets/js/adobe.96e9faf8b6c1f28df89d.js></script></body></html>